When do you need an ELD?

Operators and drivers who were using paper logs or logging software need to be using an approved ELD  like EZ-ELD NOW. (The law came into effect on December 18, 2017.)

Operators and drivers already using a compliant AOBRD will need to install an approved ELD by December 16, 2019.

Find out more about EZ-ELD.

 

EZ-ELD-Phone-device-connectors